Commit 65eb59b4 authored by Rahix's avatar Rahix
Browse files

fix(docs): Add a warning when using Sphinx 3



Hawkmoth is not yet working with Spinx 3; issue a warning when detecting
a Sphinx 3 environment as the resulting docs will be broken.

Signed-off-by: Rahix's avatarRahix <rahix@rahix.de>
parent cda44b6c
......@@ -15,6 +15,14 @@ sys.path.insert(0, os.path.abspath("./"))
logger = sphinx.util.logging.getLogger("card10/conf.py")
# Hawkmoth does not yet support Sphinx 3
#
# See https://github.com/jnikula/hawkmoth/issues/17
if sphinx.version_info[0] > 2:
logger.warning(
"Sphinx versions >= 3 are not yet working properly with hawkmoth. Documentation of C items will probably be broken ..."
)
# -- Project information -----------------------------------------------------
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment