1. 17 Jul, 2009 1 commit
  2. 08 Jul, 2009 1 commit
  3. 28 Jun, 2009 1 commit
  4. 25 Jun, 2009 1 commit
  5. 23 Jun, 2009 17 commits
  6. 21 Jun, 2009 1 commit
  7. 18 Jun, 2009 2 commits
  8. 17 Jun, 2009 1 commit
  9. 13 Jun, 2009 1 commit
    • zwelch's avatar
      David Brownell <david-b@pacbell.net>: · 4f459253
      zwelch authored
      OpenOCD doesn't actually *need* to be keeping all TCP ports
      active ... creating security issues in some network configs.
      
      Instead, let config file specify e.g. "tcl_port 0" (or gdb_port,
      telnet_port) to disable that particular remote access method.
      
      
      git-svn-id: svn://svn.berlios.de/openocd/trunk@2240 b42882b7-edfa-0310-969c-e2dbd0fdcd60
      4f459253
  10. 09 Jun, 2009 1 commit
  11. 31 May, 2009 3 commits
  12. 27 May, 2009 2 commits
  13. 24 May, 2009 1 commit
    • zwelch's avatar
      David Brownell <david-b@pacbell.net>: · 5ecae346
      zwelch authored
      Make startup for the various server ports be quiet, unless
      debugging is active:  don't emit needless scarey messages.
      Update the relevant documentation and its references:
      
       - For these port commands ... cover the default values;
         convert to @deffn syntax; include their use outside of
         the configuration stage; and alphabetize.
      
      Similar updates to the rest of that small chapter:
      
       - Highlight that there even *IS* a configuration stage, after
         which some command functionality is no longer available.
      
       - For GDB commands ... convert to @deffn syntax; alphabetize;
         include a missing command (!); add missing helptext (!) for
         one non-missing command; update relevant cross-references
         and index entries.
      
      
      git-svn-id: svn://svn.berlios.de/openocd/trunk@1909 b42882b7-edfa-0310-969c-e2dbd0fdcd60
      5ecae346
  14. 13 May, 2009 1 commit
  15. 11 May, 2009 3 commits
  16. 10 May, 2009 1 commit
  17. 08 May, 2009 1 commit
  18. 02 May, 2009 1 commit
    • zwelch's avatar
      Update autotools scripts to require automake 1.6. The configure.in script · 66add57a
      zwelch authored
      already required autoconf 2.59 (circa 2006), so there is no reason to
      support versions of automake older than 1.6 (circa 2002).
      
      The first part of this patch upgrades the configure.in script:
      
           1. Use current calling conventions for the AC_INIT and
              AM_INIT_AUTOMAKE macros, bringing their usage up-to-date with
              the version of autoconf already specified by AC_PREREQ.
           2. Add AC_CONFIG_SRCDIR macro, required by new version of AC_INIT.
           3. Automatically enable all of automake's warnings except Makefile
              portability (which OpenOCD violates by using GNU make's $(wildcard)).
              [[ While automake has its own -Werror option, I did not enabled it
              due to existing warnings. ]]
           4. Add the missing AM_PROG_C_O check, required by the build rules for
              openocd.o in src/Makefile.am.
           5. Adjust version number to show progress toward the next release.
           6. Include a bug reporting e-mail address to direct users to this list.
      
      This patch makes the following adjustments to the Makefile.am files:
      
           1. Update AUTOMAKE_OPTIONS to require automake version 1.6
           2. Rewrite all deprecated INCLUDES assignments as AM_CPPFLAGS
           3. Clean-up all AM_CPPFLAGS declarations to be patch-friendly.
           4. Remove vestigial references to $(all_includes)
           5. Remove erroneous references to @CPPFLAGS@ (only use AM_CPPFLAGS)
           6. Remove unused -I and -D directives in helper/, flash/, target/
      
      
      git-svn-id: svn://svn.berlios.de/openocd/trunk@1591 b42882b7-edfa-0310-969c-e2dbd0fdcd60
      66add57a