• zwelch's avatar
    Update autotools scripts to require automake 1.6. The configure.in script · 66add57a
    zwelch authored
    already required autoconf 2.59 (circa 2006), so there is no reason to
    support versions of automake older than 1.6 (circa 2002).
    
    The first part of this patch upgrades the configure.in script:
    
         1. Use current calling conventions for the AC_INIT and
            AM_INIT_AUTOMAKE macros, bringing their usage up-to-date with
            the version of autoconf already specified by AC_PREREQ.
         2. Add AC_CONFIG_SRCDIR macro, required by new version of AC_INIT.
         3. Automatically enable all of automake's warnings except Makefile
            portability (which OpenOCD violates by using GNU make's $(wildcard)).
            [[ While automake has its own -Werror option, I did not enabled it
            due to existing warnings. ]]
         4. Add the missing AM_PROG_C_O check, required by the build rules for
            openocd.o in src/Makefile.am.
         5. Adjust version number to show progress toward the next release.
         6. Include a bug reporting e-mail address to direct users to this list.
    
    This patch makes the following adjustments to the Makefile.am files:
    
         1. Update AUTOMAKE_OPTIONS to require automake version 1.6
         2. Rewrite all deprecated INCLUDES assignments as AM_CPPFLAGS
         3. Clean-up all AM_CPPFLAGS declarations to be patch-friendly.
         4. Remove vestigial references to $(all_includes)
         5. Remove erroneous references to @CPPFLAGS@ (only use AM_CPPFLAGS)
         6. Remove unused -I and -D directives in helper/, flash/, target/
    
    
    git-svn-id: svn://svn.berlios.de/openocd/trunk@1591 b42882b7-edfa-0310-969c-e2dbd0fdcd60
    66add57a
Makefile.am 2.32 KB